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MPA and Fisheries simulator 
Version 1.0.4 beta 

Instructions 
28 August 2018 

This manual for the Fisheries Spatial Model software takes the form of a worked example using files 
supplied in case_study_example_files. Additional parameters and options are explained at the relevant 
points in the document. NOTE: For installer downloaded from iwlearn.net, please change the file 
extension from '.pdf' to '.exe' before attempting to install the software.

0. Reference quick tips for use and input file preparation

Important points for best performance of the software: 

1) Minimise the physical size of input files. Raster files larger than 20000 x 20000 pixels may not load.
Land mask raster data does not need to be much bigger than 1000 x 1000 pixels over the modelled
area. Background images are cosmetic purposes only and should be low resolution.

2) Planning unit shapefiles should be arranged as one feature per planning unit. For planning units that
are multiple polygons, these should each be a single feature types of “multi-polygon” (or
wkbMultiPolygon) containing the separate polygons.

3) The software was designed against a reference dataset with 150 planning units and is untested for
more than 300 planning units. Optimisation will be increasingly less effective with more planning units.

4) If you intend to use the seascape distance calculation, ensure planning units polygons do not
overlap the land mask, or minimise it. The model has some capacity to handle this overlap but it can
cause problems.

5) For the best performance, the seascape distance calculation grid should be less than 600 grid cells
along an edge. Increase the cell size to achieve this. Grids with edge lengths of up to 1000 or more
can be used but the calculation will be slow.

1. General information

1.1) Note that window layout can be adjusted by dragging left and right in the middle of the vertical 
edges between panels, as well as by dragging up and down just above the tabs. You can hide the 
whole panels by dragging these points to the window edge. The layout is recalled when the software 
is exited and run again. 
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If the view area is dragged down to fill the whole of the central area, the controls for viewing the 
animation or connectivity (see further below) will not be visible. To make them visible, select the menu 
item View > Animation on all tabs, or View > Connectivity on all tabs. 

2. Load background image (an optional but helpful step) 

2.1) Go to menu File > Load background image and select “sawai_background_l8_rgb.tif”. 

2.2) Accept the default options in the window that appears and click OK. The image should appear in 
the view area, which can be navigated by clicking on “+” and “-“ buttons and left-clicking and dragging 
on the view area to pan. “Fit” resets to display whole image. 

Note: If the loaded image has three or more bands, the first three bands are interpreted as blue, green 
and red. If the loaded image has one or two bands, the first band appears as a monochrome image. 
This choice can be changed in the window that appears when the image is loaded, or at any time using 
the menu View > Change background image colour layers. The brightness and contrast is set 
automatically.  

The background image can be hidden and made visible by the menu option View >Background image. 

3. Generate planning units 

3.1) On the “Planning Units (PU)” tab select “Grid”. 

3.2) Go to menu File > Load raster data and select “sawai_land1_reef2_mask.tif”. This is a single layer 
GeoTIFF that has both the land mask (pixel value = 1), and reef mask (pixel value = 2). 

3.3) Note: “Area mask” on the Planning Units tab will now list this GeoTIFF (because it is currently the 
only raster or shapefile data loaded. Change “Value” to “2” and select “View”. 
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Reefs should appear in grey like this: 

 

3.4) Click “Reset” button and a red rectangle will appear which by default is set to the extent of the 
raster file or shapefile that was defined earlier to contain the reef data. In this example, that area is 
slightly larger than the background image (see below). This rectangle is the area that will be considered 
when generating planning units. Use the mouse to drag it at the corners. Clicking “Reset” again will 
reset it. It is OK to leave the rectangle larger since the excess area will be ignored. 

 

3.5) For this example leave “Subset to area mask” and “Make disjoint segments...” unchecked. 

3.6) Click “Generate” button at the bottom of the Planning units tab. This action generates square 
planning units over the reefs. The default size is 1km (set in the “Cell size” entry) and in this example 
below there should be 157 of them. Note: this information is shown at bottom left of the window. 
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3.7) Planning units can be saved through the menu option Planning Units > Save planning units. The 
file is saved as a ‘.shp’ shapefile. Previously saved planning units can also be loaded via the Planning 
Units menu. Planning unit shapefiles prepared in other software can be loaded provided they are in the 
correct format, as explained in the section ‘File Formats’ at the end of this document. 

4. Generate distance matrix – quick version (direct) 

The next step is to generate a matrix of distances between every pair of planning units. The quickest 
method is to use direct distance calculation but it is also useful to do this before calculating the seascape 
distances to demonstrate the difference. Direct distance calculation works out distances between 
planning unit centres using a straight line. The seascape method (see below) takes into account the 
distance around headlands and islands. 

4.1) Select the “Distance Matrix” tab. 

4.2) Select “Direct” and click the “Generate” button. The matrix of distances is generated as direct 
distances between planning unit centres (in a straight line). 

5. Review distances between planning units 

To select a planning unit, left-click in the image view area. It will be highlighted in yellow. To select a 
second planning unit, shift + left-click on another planning unit. It will also be highlighted in yellow. At 
the bottom right of the window under “Selected planning units” the planning units are listed and the 
calculated distance between them is shown together with the direct distance. The latter is for reference 
when the seascape distance calculation is used. 

 

 

 

  



 
 
 
 
 

MPA and Fisheries Simulator: instructions 5 

6. Generate distance matrix – seascape method 

6.1) Select “Seascape” on the “Distance Matrix” tab. 

6.2) The land mask will be set up previously since the required raster file was already loaded and the 
value for the land mask is 1. Click “View” and the land should appear in grey. Like this: 

 

6.3) Note: The “Doman” box (white rectangle above) is automatically set and looks as above. If it does 
not appear, click “Reset”. This rectangle defines the spatial limits of the computation. The simple 
interpretation is that if larvae disperse outside of this box they are assumed lost to the system. You can 
adjust the box using the corner handles.  

6.4) The default parameters work well for this example. Click “Generate”.  

The calculation should take about two to three minutes on a normal computer. To demonstrate the 
effect of the seascape method of distance calculation, pick two planning units on the opposite side of 
an island or headland and note the difference between the calculated distance and the direct distance. 
Using the same two planning units from before, it can now see their distance is considered to be 4.5 
km, which better reflects the distance around the headland.  

Note: In some cases, the seascape distance estimate can be slightly less than the reported direct 
distance, which is due to differences in where the centre of a planning unit is considered to be. This is 
not an error. 
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The two parameters that it may be useful to adjust in other situations are the “cell size” and “adjustment 
window”.  

Cell size: The calculation of seascape distances is based on a random route on a grid. “Cell size” is 
the size of the cells on this grid. Reducing the cell size increases the accuracy of the calculation but the 
calculation may take much longer to process. Increase the cell size to reduce the grid to a size less 
than 600 x 600 cells. The grid can be previewed by clicking on “Initialise grid”. The land mask on the 
seascape grid will be shown in white, like this: 

 

Since the seascape calculation only requires the land data at this resolution, there is no need to load 
very high-resolution land masks. For overall performance, it is recommended to minimise the resolution 
of the land mask and subset to the relevant area only before loading the raster data into the software. 
It is best to minimise any overlap of planning unit polygons with the land mask.  

To calculate seascape distance, the starting point of fish movements needs to be in the sea. If polygons 
overlap the land, the software tries to determine a reasonable starting point in the sea. It has algorithms 
for doing so which can handle a small amount of overlap but they can fail in some situations (see window 
setting adjustment below).  

Another situation that can occur is that the seascape grid land mask can contain isolated sea areas if, 
at low resolutions, narrow channels appear closed. If planning units occur in such areas they will be 
cut-off from the other planning units and will have very large distance estimates. The software issues a 
warning if this occurs. To eliminate or minimise these occurrences, the current advice is to adjust the 
cell size and seascape grid location  

Adjustment window: This allows the program to look to adjacent cells in the seascape grid if the actual 
planning unit centre lies in the land mask, so it can find a notional planning unit centre not in the land 
mask. The default value of two means the program can look up to two cells (in the above example, 2 x 
150 = 300 m,) away from the actual centre. If this is still not enough, the program will issue a warning 
to adjust this parameter or improve the land mask. 

6.5) The current distance matrix can be saved, via the menu Distances > Save distance matrix, or 
loaded via Distances > Load distance matrix. 

7. Generate and view connectivity (optional) 
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On the “Connectivity” tab, it is possible to generate the larval dispersal connectivity matrices for each 
species in the model and interactively view connectivity between planning units. This is an optional step, 
because when the model runs, these dispersal matrices will be automatically calculated anyway. 
However, on this tab you can also save or load a connectivity matrix. 

7.1) Click “Generate” under “Calculate matrix” on the species of interest (Species 1). 

7.2) Select the “View” check box on the right-hand side, and then adjust the slider. A line is drawn for 
connectivity higher than the threshold set by the slider. 

 

Using the checkboxes at the bottom, it is possible to show the connectivity between all planning units, 
with or without arrows showing their direction. You can also show connectivity into or out of specific 
planning units. For the latter, select planning units by clicking on them, or use shift-click to select two 
planning units.  

Self-connectivity can also be displayed. In which case a dot is placed in the planning unit for a measure 
of self-connectivity higher than the current threshold.  

Note: Self-connectivity varies because the matrix is normalised so there are no losses. A planning unit 
that is not well connected to other planning units has high self-connectivity. 

The “Save” button will save the connectivity matrix for the species as a comma-separated text file (CSV) 
file. The “Load” button also will load a matrix from a CSV file. The format of these files is the same as 
distance matrix files, but they store relative connectivity derived from the distance matrix and the 
individual species range parameters, editable on this tab.  

8. Select planning units for inclusion in the MPA, and to define key fishing grounds 

8.1 Crtl left-click on planning units in the view area to select and deselect them for inclusion in the 
MPA. They can also be selected by using the checkboxes under “MPA” on the list to the left. Planning 
units for inclusion in the MPA are shown in blue (see below). 

8.2 It is also possible to define planning units as part of key fishing grounds. Later, results can be shown 
for the key fishing grounds in isolation. The optimisation can also work specifically on the key fishing 
ground catch. Crtl+shift left-click on planning units in the view area to select and deselect them as 
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being key fishing grounds. They can also be selected by using the checkboxes under “key” on the list 
at the left. Planning units for defining key fishing grounds are outlined in white (see below). 

A good example is to select the planning units of the North Western island: 

 

Here the smaller region in the south east has been selected as key fishing grounds, as shown by the 
white border. 

Both the list of MPAs and key fishing grounds can be saved and loaded as text files, under the menu 
options Planning units > Load MPA selection and Planning units > Save MPA selection, and 
likewise Planning units > load key fishing ground selection and Planning units > save key fishing 
ground selection. 

9. Configure species parameters 

9.1) The number of species is set in the options dialog, accessed through the menu Options > Options. 
For the current example leave the number of species as “1”. 

9.2) Species parameters are shown and can be edited on the “Model” tab. Once the number of species 
has been set, each species can be edited individually by selecting the species name under the “Name” 
selection box. The other parameters then correspond to that species. 

 

If the dispersal parameters appear grey, this is because a dispersal matrix has already been calculated 
or loaded under the “Connectivity” tab. To enable those options, go back to the “Connectivity” tab and 
click on the “Clear” button for the required species. This action will clear the pre-calculated dispersal 
matrix. The new matrix will be calculated when the model is run, based on the dispersal entries. If the 
dispersal entries do not need to be changed, there is no need to do this.  

For the purposes of the worked example, leave the default Brown Trout settings as supplied. 
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The meaning of the parameters is as follows: 

s Natural annual survival. Proportion of the fish biomass not dying from senescence or other 
natural causes. Annual natural mortality = 1- s. 

p Brody growth coefficient. Rate of growth in fish biomass when fish biomass is low 
(equivalent to van Bertalanffy’s K). 

h Post-settlement larval mortality. This so-called steepness parameter changes the 
proportion of unfished larval supply needed to sustain a given population size. For the 
lowest value (h = 0.2), for example, all naturally settling larvae (unfished conditions) are 
needed to sustain maximum population sizes. For the maximum value of h (h = 1), 
recruitment of young fish into the population is constant, no matter how many larvae settle. 
Values between 0.3 and 0.95 are realistic. 

wRec Weight at recruitment. The weight in kg (or other units if desired) of an individual fish when 
it reaches maturity. 

wPre Weight prior to recruitment. The average weight in kg (or other units if desired) of an 
individual fish before it reaches maturity. 

weight This a relative weighting factor for multiple species runs, to prioritise certain species in the 
results [Note this parameter may be removed from future versions]. 

 

10. Configure species-dependent spatial parameters 

There are three potentially species dependent parameters that need to be set for each planning unit: 
Larval output, Habitat Quality and Fishing Effort. You can set these individually for each species or you 
can define values common to all species. If “Species Specific” is checked, then the edits apply only to 
the currently selected species. Otherwise default settings will be applied and will be used for any 
species that does not have a specific setting. 

10.1) Under “Larval output” select “PU data” and select “mask_area” to the right of that. “Larval Output” 
should normally be the area of reef within each planning unit. By default it is set to “PU area” (Planning 
Unit area), but that is for planning units that are shaped to fit the reef, created using the option “Subset 
to area mask” when the planning units were defined. In the current example, the planning units are 1 
km x 1 km squares. “Mask_area” is the column of planning unit data that contains the actual area of 
reef in each planning unit.  This was calculated when the planning units were defined. 

10.2) Leave “Habitat Quality” and “Fishing Effort” as “Uniform”. 

Possible spatial data options 

(To proceed with the current example, this section can be skipped) 

Uniform – the same value in every planning unit (1) (note that typically it is the relative values that are 
important, so a 1 in all planning units would be the same as a 10 in all planning units). 

PU Area – this is just for larval output and it sets the larval output as being proportional to the area of 
the planning units. It only makes sense when planning units are clipped to the reef area, using the 
option “subset to area mask” when generating the planning units. 
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PU Data – this takes the value from one of the columns in the planning unit list on the left. This can be 
the area of the reef in the planning unit (under “mask_area” in this example) or another field that was 
included if a shapefile of planning units was loaded. 

Spatial – this will take the average value found within each planning unit from a loaded spatial data set 
– either a GeoTIFF image or shapefile. The file must be loaded under the menu option File > Load 
raster data or File > Load shapefile data.  For raster data, it is necessary to specify from which band 
of the image the data should be taken. For a shapefile, the layer and field name of the data must be 
specified. 

IMPORTANT: Note: All spatial data to be loaded (raster or shapefiles) must contain an embedded 
geo-projection that allows latitude-longitude to be deduced, for which the geo-referenced co-ordinate 
system is in units of metres. Shapefile support is also limited to Polygons and Multi-polygons. For 
raster data, GeoTIFF is recommended although other file formats may also work. 

11. Configure costs 

Under “Costs” it is possible to set a cost for each planning unit in the same manner as above. This is 
not species specific. 

11.1) Leave “Costs” set as “Uniform”. 

12. Run model 

12.1) Under “Model run” on the “Model” tab enter a name for the results. The default called “01_Results” 
is OK. The purpose of naming results is that results are stored, and results that are named differently 
can be compared afterwards.  If a second run is performed with the same results name, it will overwrite 
the previous results of that name. 

12.2) “Years to run” is the number of years the model will be run and “Year of MPA implementation” is 
the year in that run at which the MPA will be established. Leave these as the defaults of 100 and 25, 
respectively. 

12.3) Click “Run”. Processing should only take a few seconds and at the end the plot at the top right 
should have a red line appear in it. 

There are various other settings regarding the model configuration that are set from the menu Options 
> Options. By default, the example has implemented a no-take MPA within the selected planning units. 
The other options are described at the end of this document.  

13. View results 

The charts that appear on the right show results for the total overall planning units (top chart) and for 
the planning units selected in the view area (bottom chart) (i.e. highlighted in yellow by left-click and 
Shift left-click). 
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If more than one run has been performed and those 
runs were named differently, then you can compare 
these on the plots. 

For example, change the MPA selection and 
change the model run name from “01_Results” to 
“02_Results”, then click “Run” again. 

Now click “Add Line” at the bottom right of the 
window under the plots. Select “02_Results” in the 
box and click on the small red square to change the 
colour of the line. The plots should now look 
something like the image to the right. 

By selecting different options on the row of entries 
that define each line, it is possible to show results 
for total biomass, catch and individual species, 
inside and outside the MPA and for key fishing 
grounds only. 

The two buttons directly under the bottom plot allow 
results to be shown as relative biomass, either as a 
% of initial biomass or of the theoretical maximum 
sustainable yield; or in physical weights, which will 
then be in the same units as wRec and wPre in the 
species parameters. 

 
 

14. Review and save results 

Under the “Review” tab, previous runs can be reviewed and results saved to a comma separated text 
file (CSV file). It is also possible to view an animation of catch or biomass over time overlaid on the view 
area. In the image below two runs have been performed: 

 

14.1) To save the results from a specific run to a CSV file, select the relevant row in the table and 
click on the button “Save selected results”. 

14.2) To view an animation of the results, similarly select the row containing the run and click “Load 
MPA from selected”. This step ensures the MPA selection and key fishing grounds shown in the view 
correspond to the results being viewed. The animation places a yellow disc in the centre of each 
planning unit, the area of which is proportional to the catch or biomass in that planning unit (depending 
on which output is selected). The basic size of the discs is set by “Symbol size”. The controls at the 
bottom will play and stop the animation, or the slider can be used to interactively move through time. 
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15. Optimisation 

To perform an optimisation run, the configuration is exactly the same as a standard run described so 
far except that it is not necessary to specify the planning units that are part of the MPA, since this is 
what will be determined by the optimisation algorithm. However it is possible to indicate planning units 
which must be included in the MPA and ones which must not be included in the MPA. This is achieved 
by selecting planning units under the “Inc.” (include) and “Exc.” (exclude) columns which appear when 
the “Optimisation” tab is selected. Note: there is no visual indication of these states in the view. 

 

To continue with the worked example select the “Optimisation” tab and configure an optimisation run 
as follows. This is the default setting so no changes should be necessary: 

 

This will run an optimisation to maximise the total catch and the compactness of the MPA, with the 
same priority weight on both factors. Other relevant options are on the options tab under the menu 
Options > Options, but provided these have been left in the default values this will generate a no-take 
MPA. The result should look like the image below, although there are random elements to the 
optimisation so the results may be slightly different. 
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Now as an experiment, define a key fishing ground by Shift-ctrl clicking on planning units as shown in 
white below: 

 

On the optimisation configuration, uncheck “Maximise total catch” and instead check “Catch in key 
fishing grounds”. Run the optimisation again and the result should look something like this: 
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As expected, the selected MPA is closer to the key fishing grounds, since the connectivity between the 
key grounds and the MPA is therefore higher. However the area of the MPA is rather large at 58 km2, 
since no limit on the area was entered, other than aiming for compactness. Add “Target area” as a 
priority and set the maximum area as 20 km2. Like this: 

 

Now the result looks like this: 

 

The area has been substantially reduced, but the MPA has an area of 30 km2 and has not achieved the 
limit of 20 km2. This demonstrates an important principle with defining multiple priorities - bear in mind 
that the target area was just one of three optimisation criteria.  
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Now increase the priority of achieving the target area from “1” to “5”. Run the optimisation again, and 
something like this is result: 

 

This MPA has an area of 19 km2, on target but at the cost of compactness and also the catch in the key 
fishing grounds is slightly lower. In practice a fragmented set of planning units like this is probably not 
practical to implement. The best way to use the optimisation is as a guide to the important areas, and 
then use a standard run on hand-crafted MPAs to establish a good practical solution. 

The software provides many options for controlling the optimisation and the best way to use this 
functionality is complex, which often produces unexpected results. In general, the best way to run the 
optimisation is a subject of ongoing research, a certain amount of trialling is currently required. 

The next section provides more detailed guidance on the optimisation options. 

Optimisation Priorities 
The optimisation attempts to select planning units for inclusion into the MPA based on a number of 
criteria. The software allows weights to be ascribed to priorities and also assign a “tolerance” below 
which improvements will be ignored. For example, “Compactness” aims to prioritise planning units being 
selected in a physically smaller area rather than being spread around. This is based on the distance (in 
km) across the area containing the MPA planning units. If a tolerance value of ‘5’ is set this means that 
“compactness” will be ignored for two possible MPAs that differ in their compactness by less than 5 km, 
allowing other priorities to dominate.  
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The various criteria listed should be self-explanatory. Note: “Fast recovery” refers to the number of 
years required to reach 99% of the final total biomass, regardless of the actual final biomass. So an 
MPA design where the population does not recover may still be considered to have a “Fast recovery”. 
“Target area” means that solutions will be selected that are within the physical area set by the “Minimum 
area” and “Maximum area” options set in the right hand panel.  

Unchecking “Use” for a particular criteria is equivalent to setting its weight to zero. A weight can be any 
positive number. It is important to realise that individual priorities and combined priorities may have 
counter-intuitive consequences. For example, minimal cost is achieved by no MPA at all. 

Optimisation Parameters 
There are a number of parameters that control the optimisation process that can be set on the right 
hand side of the Optimisation tab. The optimisation can be configured to operate like “greedy algorithm” 
or more like a “simulated annealing” algorithm, or something in-between. Both approaches have pluses 
and negatives, and the most efficient method requires trial and error to determine. The optimisation 
works by maintaining a pool of potential candidate solutions, assessing which are the current best 
solutions and generating a new set of solutions from those. The maximum size of the set to be 
maintained is set by the “Set size” parameter and the maximum number of iterations (new set 
generations) is set under “Passes”. 
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PUs vs. Area − this controls how the optimisation is initialised. “PUs” means that the initial set of 
solutions is simply each individual planning unit. As the solution progresses good solutions are 
combined together so this option behaves like a greedy algorithm. A consequence of this approach is 
that certain planning units which are by themselves good solutions tend to always be selected. If this 
leads to undesirable results, those planning units can be excluded to force other solutions to be found. 
“Area” initialises the candidate sets with random selections of planning units up to the specified area. If 
the initial area is small the algorithm is still like a greedy algorithm, but if it is large then the optimisation 
proceeds more like simulated annealing, provided the “Anneal” parameter is greater than zero. 

Anneal – an essential component of simulated annealing is that in early stages of the optimisation not 
only the best solutions are maintained, but poorer solutions have a chance of being included. As the 
optimisation proceeds the probability of including poorer solutions gradually decreases to zero. The 
Anneal parameter sets the initial “disturbance” level that allows poorer solutions to be maintained. A 
value of one means that any solution has an equal chance of being selected, zero means that strictly 
the best solutions are maintained.  The specified value is what is applied on the first iteration, it linearly 
declines to zero at the last iteration (pass).  The disadvantage of simulated annealing type approaches 
is that they are very inefficient, the set size and number of passes need to be substantially larger for 
this approach, leading to long solution times. 

Minimum area and Maximum area – these define the target area for the MPA, for the “Target area” 
criteria. 

Maximum number of planning units and Maximum costs – these are hard limits that will not be 
exceeded by the optimisation, solutions that exceed these values will not be considered. 

Probability of inverting PU inclusion – this additional option appears in the options dialogue under 
the menu Options > Options. It is another parameter relevant to simulated annealing-type of approach. 
This parameter adds another level of random perturbation to the optimisation process, where new 
candidate solutions can have random planning units included or excluded based on this parameter.  
The value represents the probability of inverting the inclusion or exclusion of each planning unit, but 
weighted so on average the same number of planning units are included after disturbance. A value of 
zero turns this off, and a value of 1 is the maximum. It is recommended to maintain a small positive 
value, such as the default of 0.01. 
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16. Additional MPA parameters 

Additional parameters governing the MPA implementation can be accessed in the options dialogue 
from the menu entry Options > Options.   

 

MPA Implementation 

“No take” means that the fishing effort will be set to zero in the MPA area. “Reduce effort” will lower the 
effort in the MPA to a proportion of what it was before MPA implementation (0% = no take). In either 
case fishing effort outside the MPA is increased so that the total effort is maintained. 

Dynamic fishing effort 

Allowable fishing effort is scaled according to the fish biomass. In other words, fishing effort is higher 
where fish are found. The ‘c parameter’ adjusts this effect from zero, which equals no dynamic fishing 
effort, to a value of 5 which is equivalent to maximum effect. The c value can be set with different values 
applied before MPA implementation and then inside and outside the MPA. 

Total allowable catch (TAC) 

It is also possible to limit the catch before MPA implementation, as well as inside and outside the MPA. 
The value entered is the total catch for that region in the same units as wPre and wRec in the species 
configuration. The figure appears on the result plots as “Total Catch”, in absolute units.  

Performing an initial run can give you an idea what is a realistic value for this parameter. If you wish, 
for example, to set a catch limit inside the MPA but have no limit outside the MPA, simply set the TAC 
for outside the MPA to a very high number and no limit will be applied.  
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Harvest rate 

It is possible to set the harvest rate as being equal to the maximum sustainable yield (MSY), as a 
multiple of the MSY or as an absolute rate. Again, three values can be applied before MPA 
implementation and inside and outside the MPA. The value entered as ‘u’ in the table will either be the 
multiple of MSY or the absolute value depending on which option is selected. 

17. File Formats 

17.1) Planning Units. 

The ESRI shapefile format has many options and not all features are supported in this software. Files 
with unsupported features should load, but the unsupported components are ignored and will be 
discarded. Planning unit shapefiles are of the following format: 

1) A single layer. 
2) The layer contains a set of features, where each feature is one planning unit and of a ‘well-

known binary type’: wkbPolygon or wkbMultiPolygon. Note: there is 1:1 correlation between 
features and planning units. That means the number of features is the number of planning units. 

3) Where one planning unit consists of more than one polygon it should be a wkbMultiPolygon, 
the multiple polygons being separate polygons of the planning unit.  

4) Polygons may have one or more holes. 
 

When preparing a planning unit shapefile in other software, a simple format where each planning unit 
is a single polygon will most likely be saved in the correct format by most software. When planning units 
are multiple polygons, please note that these cannot be saved as a single list of separate polygons as 
they will be interpreted as separate planning units. The multi polygon feature type must be used. Consult 
the documentation of the software being used to prepare the shapefiles to determine how to achieve 
this. This technical link may be useful: 

http://edndoc.esri.com/arcsde/8.3/sql_interface/concepts/the_well_known_binary_representation.htm    

17.2) Raster Data. 

The fisheries spatial model is not a full GIS or image processing solution and therefore has some 
limitations in the handling of raster data. In particular, very raster large files, with x and y pixel 
dimensions in the tens of thousands, will take up a lot of memory, reducing software performance and 
possibly not being able to be loaded. It is therefore recommended to prepare raster data inputs so that 
they are at the minimum required resolution, as this will increase the performance of the software. 

1) Background image. This image is for cosmetic purposes only, to visually orientate where planning 
units are located. It is recommended to ensure this is of a relatively low spatial resolution, e.g. less than 
1000 x 1000 pixels. When viewing the full area in the software, a resolution of more than a few hundred 
pixels is not visible. 

2) Land and reef mask. The land and reef mask does not need to be at a substantially higher resolution 
than will be used by the software in the modelling process. This mask will be queried at a specified 
resolution in two aspects of the modelling process: generation of planning units (reef mask) and 
seascape distance calculation (land mask). The seascape distance calculation was discussed 
previously. The land mask does not need a higher resolution that 1000 x 1000 pixels over the area to 
be modelled. A reef mask is only required if the planning units are defined in the software and not loaded 

http://edndoc.esri.com/arcsde/8.3/sql_interface/concepts/the_well_known_binary_representation.htm
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from a shapefile. In that case, a high-resolution reef mask may be useful if there are small reefs that 
need to be included. Note: the reef mask will be queried at a resolution which is set on the option 
‘sample distance (m)’ under the Planning Units (PU) tab “Grid” option. 

 

If this is set at 1000m, for example, it means the reef mask will be queried at points 1000m apart, so 
loading a reef mask of resolution 100m would be unnecessary. A more appropriate resolution would be 
1km or more.  

The sample distance should always be equal to or smaller than the mask resolution otherwise; a single 
pixel of data could be missed. If the reef mask is very high resolution and cannot be loaded into the 
software, prepare a lower resolution version in external software such as QGis, ENVI or Erdas Imagine. 
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